Exchange 2016 Product Version Numbers

Updated on 18 October 2018 IMPORTANT: With CU11 for Exchange 2016… .NET Framework 4.7.2 is now supported and will be a requirement with CU13 (anticipated release in Jun 2019); Visual C++ 2013 Runtime is still a requirement; and Visual C++ 2012 Runtime is a new requirement. With CU8 for Exchange 2016, .NET Framework 4.7.1 is…

Disable SSL 3.0 Protocol for Exchange 2013 (pre-CU8)

Prior to the release of CU8 for Exchange Server 2013 yesterday, you may have been prompted with an error (similar to the screenshot below) while validating or checking the installation of your SSL certificate. For all of my Exchange projects, I will check validity of the certificates installed by running the DigiCert SSL Installation Diagnostics Tool. In this instance, an error…